Как мне доказать на апелляции, что я это задание решил на 2 балла, а не на 1? вот мое решение:Алгоритмический язык:max:=100нц для i от 1 до Nесли a[i]

1 Январь 0001



Как мне доказать на апелляции, что я это задание решил на 2 балла, а не на 1? вот мое решение:
Алгоритмический язык:

max:=100
нц для i от 1 до N
если (a[i]>=100) и (a[i]<=999) и (mod(a[i],3)<>0) и a[i]>max то
max:=a[i]
все
кц
если max=100 то
вывод ‘не найдено’
иначе
вывод max
все

  • В решении нет ошибок.

    Чтобы доказать нужно протрассировать этот алгоритм с разными входными параметрами.

    А они могут быть двух типов:

    1) Без искомого числа [1,3,9,100,101,200,201]

    2) C искомым числом [1,3,9,100,101,200,201,333,666]

     







Информатика

Комментарии закрыты.